Back to overview
Downtime

files.thisisnotawebsitedotcom.com/is-it-time-yet/well-is-it.txt is down

Aug 1, 2024 at 5:15pm UTC
Affected services
files.thisisnotawebsitedotcom.com/is-it-time-yet/well-is-it.txt

Updated
Aug 1, 2024 at 5:19pm UTC

files.thisisnotawebsitedotcom.com/is-it-time-yet/well-is-it.txt went down.

Created
Aug 1, 2024 at 5:15pm UTC

files.thisisnotawebsitedotcom.com/is-it-time-yet/well-is-it.txt went down.